TLS 1.0 and 1.1 are now deprecated, disabled in Nightly

Published: | Categories: Networking, Privacy & Security

Description

The support for Transport Layer Security (TLS) 1.0 and 1.1 has been deprecated and will be removed from all major browsers in March 2020. The older versions of TLS are now disabled by default in Firefox Nightly in preparation for the removal, which means the browser shows the Secure Connection Failed error page to prevent access to web servers not using TLS 1.2 or 1.3.

Make sure to enable the newer versions of TLS on your server so it remains safe and available. See this Mozilla Hacks blog post for more information.

References