Postponed DTLS 1.0 support in WebRTC has been removed

Published:

Categories: Audio & Video, Networking, Privacy & Security

Releases: Future

Description

Firefox 75 80 has bumped the default minimum version of Datagram Transport Layer Security (DTLS) in WebRTC to 1.2. According to Mozilla, more than 98% of WebRTC services have already adopted DTLS 1.2. If you are still using DTLS 1.0, it’s time to upgrade.

Update: Mozilla is going to temporarily re-enable the DTLS 1.0 support in Firefox 75 Beta. This is because many people are currently forced to work at home and relying on video conference solutions amid the novel coronavirus (COVID-19) outbreak, but one of these services called Jitsi doesn’t support DTLS 1.2 yet. Also due to COVID-19, Google has postponed the release of Chrome 82 that would remove their DTLS 1.0 support. We’ll update this note when the situation has changed.

Update 2: This change is shipping with Firefox 80.

Update 3: The change has been postponed again because Google is not yet ready to do the same in Chrome.

References