Web Crypto API is no longer available on insecure sites

Published:

Categories: Privacy & Security

Releases: Firefox 75, Firefox 78 ESR

Description

Starting with Firefox 75, the Web Crypto API will only work on secure sites served over HTTPS, as required by the current spec. window.crypto.subtle will be undefined on insecure sites. Given that Google Chrome 60 shipped in July 2017 has already made the change, the compatibility risk should be low.

References