WebVR API が安全でないサイト上では使用できなくなりました

公開日:

カテゴリー: その他, プライバシー & セキュリティ

リリース: Firefox 73, Firefox 78 ESR

概要

Firefox 73 以降、WebVR API は、HTTPS 経由で配信された安全なサイトのみで動作するようになります。これは、この API が繊細なセンサー入力を露呈しているためです。安全でないサイト上では、関連インターフェイス、メソッド、プロパティは undefined となります。たとえデモとしてであっても何らかの WebVR コンテンツを提供している場合は、必ず HTTPS で配信しましょう。

参考資料